Back to overview
Degraded
Node-13 hardware failure
Oct 08 at 10:46am CEST
Affected services
etheron.nl
Resolved
Oct 08 at 09:27pm CEST
All Virtual Private Servers are migrated to a different node
Affected services
etheron.nl
Created
Oct 08 at 10:46am CEST
We are working on a fix.
This server is currently unavailable
Affected services
etheron.nl