Back to overview
Downtime
Web4 issues
Nov 21 at 12:13pm CET
Affected services
etheron.nl
Resolved
Nov 21 at 12:15pm CET
Should be fixed again. The webserver crashed.
We are looking into the cause
Affected services
etheron.nl
Created
Nov 21 at 12:13pm CET
We are checking
Affected services
etheron.nl